Back to overview
Downtime

Critical Site-Wide Power Loss

Jul 15 at 01:54am CDT
Affected services
Bespin AMP Service
TurkeyTom Minecraft Server
Turkey Tom Minecraft Server Map

Resolved
Jul 15 at 03:43am CDT

We have successfully brought all systems back online. All service functionality has been restored. Thank you for your patience.

Updated
Jul 15 at 03:35am CDT

Power has now been restored. Working to bring all hardware back online. Some services may still be temporarily unavailable. Please allow between 15-20 minutes for all services to become available. Thanks for hanging tight with us!

Created
Jul 15 at 01:54am CDT

Site is experiencing major power loss along with 1300+ other sites. Due to limited backup battery power, servers could only be gracefully shutdown. Power company is aware of the issue and is working on resolving ASAP.